Asset Creation Slowness in Certain Region

Incident Report for mux

Resolved

The fix resolved the issue and asset creation back to operational.
Posted Jul 21, 2026 - 01:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 01:08 UTC

Investigating

We are currently investigating slowness in asset creation that affects limited number of assets in one of our North America cloud locations.
Posted Jul 21, 2026 - 00:57 UTC
This incident affected: Mux Video - VOD.