Incomplete data in Delivery Usage API for 2021-04-26 20:31 to 2021-05-03 20:10 UTC
Incident Report for Mux
Resolved
Our engineering team has confirmed a successful full backfill of all incomplete Delivery Usage API data from 2021-04-26 12:31pm UTC to 2021-05-03 20:10 UTC. All users should now have full access to their delivery data. We appreciate your patience as we worked through this issue.
Posted May 13, 2021 - 12:13 UTC
Update
Our backfill of the impacted Delivery Usage API data continues to run. Currently, we expect half of the data to be available shortly and we expect this process to continue throughout the week. We appreciate your patience with us as we work to fill all the incomplete data, and will post our next update once we're nearly complete
Posted May 11, 2021 - 00:52 UTC
Update
Our backfill of the impacted Delivery Usage API data continues to run, though it has taken longer than initially expected. We expect this process to continue through the day. We will share progress as we have material updates.
Posted May 08, 2021 - 18:54 UTC
Update
Our backfill of the impacted Delivery Usage API data is running on schedule, and we expect all users to have full access to their Delivery Usage information from 2021-04-26 12:31 UTC to 2021-05-03 20:10 UTC within approximately 36 hours.
Posted May 06, 2021 - 02:21 UTC
Identified
The Delivery Usage API is currently reporting incomplete data from 2021-04-26 12:31pm UTC to 2021-05-03 20:10 UTC. Querying data within this range will work, though the results will be incomplete. All data before and after this time range is accurate.

We are working to backfill this data, and results for queries within this range will change as the backfill runs. Due to the large amount of data involved, we expect this process to take 48 hours or more. We will share progress here daily, or sooner if we have material updates.

All Mux Data and Video services aside from the Delivery Usage API are working as expected.
Posted May 04, 2021 - 21:15 UTC
This incident affected: Mux Video - Live.