Monitoring dashboard data delayed

Incident Report for mux

Resolved

This incident has been resolved.
Posted Feb 01, 2026 - 23:20 UTC

Monitoring

We've taken corrective action and are monitoring the results. Tail latencies have fully recovered.
Posted Feb 01, 2026 - 22:25 UTC

Update

Elevated latency in the processing of incoming monitoring data began approximately 21:35 UTC. This impacted most customers that have access to monitoring data. Latency has starting improving, and we continue to investigate root cause.
Posted Feb 01, 2026 - 22:17 UTC

Investigating

We are investigating an issue where monitoring data is significantly delayed
Posted Feb 01, 2026 - 21:56 UTC
This incident affected: Mux Dashboard and Mux Data - Data Collection.