Delayed video ingest and webhook delivery for some customers

Incident Report for mux

Resolved

After monitoring the fix we have confirmed full resolution.
Posted Feb 25, 2026 - 00:32 UTC

Monitoring

Our teams have implemented a fix to resolve the delays.

At approximately 19:53 UTC, customers may have experienced delays in video ingest time and webhook delivery. We will continue to monitor the recovery and will post an update when fully resolved.
Posted Feb 24, 2026 - 21:08 UTC

Identified

Our teams identified the cause of the delays and are actively working on recovery.
Posted Feb 24, 2026 - 20:37 UTC

Investigating

We are currently investigating delays in video ingestion and webhook delivery. Our teams are investigating and we will share an update once we have more information.
Posted Feb 24, 2026 - 20:06 UTC
This incident affected: Mux Video - VOD.