Mux Data monitoring metrics incomplete/latent

Incident Report for mux

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 20:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 19:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 05, 2025 - 18:23 UTC

Update

We are continuing to investigate where in our pipeline the latency is coming from. Customers will continue to see the leading edge of monitoring data be artificially low and fill in over time.
Posted Sep 05, 2025 - 17:53 UTC

Investigating

We are seeing intermittent drops in monitoring data starting 15:13 UTC that then fill in over time. We are currently investigating.
Posted Sep 05, 2025 - 17:20 UTC
This incident affected: Mux Data - Data Collection.