Elevated errors in Mux Data Historical metrics

Incident Report for mux

Resolved

This incident has been resolved
Posted May 07, 2026 - 23:41 UTC

Monitoring

Our team has implemented a fix and we are monitoring the results.
We’ll post an update as soon as the issue is fully resolved.
Posted May 07, 2026 - 23:18 UTC

Identified

Our team has identified the cause of elevated Data Historical metrics errors and is actively working on a fix.

We’ll continue to share updates as we have them.
Posted May 07, 2026 - 22:39 UTC

Investigating

We are currently investigating errors in Mux Data historical metrics beginning at approximately 22:08 UTC. We apologize for the inconvenience and will share an update once we have more information.
Posted May 07, 2026 - 22:32 UTC