Mux Data Pipeline Latency for EU Customers

Incident Report for mux

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 17:33 UTC

Monitoring

We are monitoring for additional latency. EU saw elevated latency 15:50 UTC to 16:04 UTC. Monitoring data was inaccurate during that window and views were delayed. No data was lost.
Posted Apr 28, 2026 - 16:22 UTC

Investigating

We are seeing some latency in both Monitoring and Historical views starting 15:53 UTC for EU customers and are currently investigating
Posted Apr 28, 2026 - 16:05 UTC
This incident affected: Mux Data - Data Collection.