Elevated AVPlayer Mux Data SDK crashes
Incident Report for mux
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 23:26 UTC
Monitoring
We have implemented a fix on Mux Video side to remove `#EXT-X-SESSION-DATA` tags from playlists. You should still upgrade to SDK version 3.5.1 or later.
Posted Jan 31, 2024 - 19:49 UTC
Identified
We have identified an issue with the Mux Data AVPlayer SDK that results in elevated app crashes under the following conditions:

- AVPlayer Data SDK version before 3.5.1
- HLS playback when the HLS playlist contains `#EXT-X-SESSION-DATA` tags

If you are experiencing this issue you should upgrade to version 3.5.1 or later.

In the meantime, for customers using Mux Video for playback, we are currently working on a fix to remove `#EXT-X-SESSION-DATA` tags from playlists to prevent this crash on older SDK versions. If you're not using Mux Video for playback you may want to consider doing the same until you can upgrade the SDK version.
Posted Jan 31, 2024 - 18:12 UTC
This incident affected: Mux Video - VOD, Mux Video - Live, and Mux Data - Data Collection.