Webhook Delivery Stalled

Incident Report for mux

Resolved

This incident has been resolved.
Posted May 14, 2026 - 20:57 UTC

Monitoring

We have identified the issue and have deployed a fix. We are continuing to monitor.
Posted May 14, 2026 - 20:33 UTC

Investigating

We are seeing high webhook delivery latency. We are actively investigating
Posted May 14, 2026 - 20:31 UTC