We are continuing to monitor for any further issues.
Posted Jul 31, 2025 - 22:51 UTC
Monitoring
The elevated latency we observed in our collection stack has been mitigated and as of 21:01 UTC we are fully recovered. We are now monitoring for additional issues.
Posted Jul 31, 2025 - 21:17 UTC
Investigating
We are not seeing a full recovery and are investigating the cause.
Posted Jul 31, 2025 - 20:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Impact mitigated at 20:29 UTC
Posted Jul 31, 2025 - 20:39 UTC
Identified
The issue has been identified and we are working on a fix. Mux Data customers are continuing to see collection degradation.
Posted Jul 31, 2025 - 20:25 UTC
Update
Beginning at 19:35 UTC, customers will see reduced CCV counts and elevated failure/exit percentages in the monitoring product. Views during this time may not have complete data. We are continuing to investigate.
Posted Jul 31, 2025 - 20:02 UTC
Update
We are continuing to investigate this issue.
Posted Jul 31, 2025 - 19:50 UTC
Investigating
We are investigating an issue where many customers are not receiving all incoming beacon data
Posted Jul 31, 2025 - 19:49 UTC
This incident affected: Mux Data - Data Collection.