Incorrect / Incomplete data in View Stream Exports

Incident Report for mux

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 20:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2025 - 19:04 UTC

Update

We have identified a fix for this issue and are working on deploying this fix. We will provide further updates as we have them.
Posted Feb 27, 2025 - 18:28 UTC

Identified

We have identified an issue where the data for each video view sent to Kinesis or Pubsub via View Stream Exports is incorrect. This started around 10PM UTC on Feb 26th, and in the video views sent, some fields such as video_duration and watch_time (and others) are reported as 0.

The data in the views via the dashboard or API are accurate, this is only in the data sent through the View Stream Exports.

Our team is working on a fix at the moment, and we will provide updates as we have them.
Posted Feb 27, 2025 - 17:34 UTC