Playback stalling on iOS, Safari on OSX, and certain other HLS players
Incident Report for mux
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 22:46 UTC
Monitoring
We have rolled out a fix ensuring that all manifests and segments are delivered through *.mux.com domains, which has resolved this issue.

Everything is functional, and we will continue to monitor the issue for any issues.
Posted Jul 10, 2020 - 21:41 UTC
Update
Short update.

This issue is not present in all live streams, as it arises in situations where multiple clients are connecting across different networks, served by the same CDN POP. This results in manifests that, while correct, can trigger these playback issues in certain HLS implementations such as Safari and iOS as hostnames and domains might change.

We are working on a fix that will stop this behavior from happening, and will serve all content through *.mux.com domains.
As part of this, if you have a CSP configured for your application, you _may_ need to update your CSP configuration, though the large majority will still work.

A valid CSP for Mux is provided below:

Content-Security-Policy: default-src 'self' *.mux.com *.litix.io
Posted Jul 10, 2020 - 21:23 UTC
Identified
We have identified an issue where certain live streams experience unexpected stalls, skips, or potential playback failures on iOS devices, Safari within OSX, and certain other native HLS implementations. Javascript-based players such as video.js and hls.js do not experience this issue.

This issue is not present in all live streams, as it arises in situations where multiple clients are connecting across different networks, served by the same CDN POP. This results in manifests that, while correct, can trigger these playback issues in certain HLS implementations such as Safari and iOS.

We are currently working on deploying a fix for this issue.
Posted Jul 10, 2020 - 21:08 UTC
This incident affected: Mux Video - VOD.