Mux.com Website unavailiable
Incident Report for mux
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 18:18 UTC
Monitoring
The Mux website was briefly down from 16:42 to 16:56, all Mux products were available normally during this time.
Posted Apr 13, 2022 - 17:00 UTC