Mux Data no longer reporting finalized views

Incident Report for mux

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 23:14 UTC

Monitoring

A fix has been implemented. Views were delayed from 2025-08-01 21:42:00 to 2025-08-01 22:06:00, and are now available in the system. Some monitoring metrics were inflated/misreported during this time.
Posted Aug 01, 2025 - 22:37 UTC

Identified

This issue has been identified as latency in our processing pipeline. There is no data loss and a fix is being implemented.
Posted Aug 01, 2025 - 22:13 UTC

Investigating

We are currently investigating an issue where views not showing up in the API or dashboard beginning 21:42:30 UTC
Posted Aug 01, 2025 - 22:06 UTC
This incident affected: Mux Dashboard and Mux Data - Data Collection.