Elevated errors in Mux Data dashboard and API

Incident Report for mux

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 18:58 UTC

Monitoring

A fix has been implemented and we are monitoring.
Posted Jun 10, 2026 - 16:11 UTC

Identified

We have identified the issue and are implementing a fix.
Posted Jun 10, 2026 - 15:10 UTC

Investigating

We are investigating an issue causing an increase in errors in the Mux Data dashboard and API.
Posted Jun 10, 2026 - 14:04 UTC
This incident affected: Mux Dashboard.