Elevated latency on Low Latency Live Streams

Incident Report for mux

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 21:46 UTC

Monitoring

As of 20:12 UTC, the team has implemented a fix and latency has returned to normal. At this point we expect all low latency live streams to be fully operational.
Posted Mar 14, 2025 - 20:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 20:21 UTC

Investigating

Starting at 17:40 UTC we began experiencing elevated latency for some low latency live stream delivery. The team is actively investigating.
Posted Mar 14, 2025 - 20:00 UTC
This incident affected: Mux Video - Live.