Mux Data Delayed Views for EU customers

Incident Report for mux

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 03:30 UTC

Monitoring

Our pipeline latency is resolved and we are caught up as of 1:50 UTC
Posted Apr 30, 2026 - 02:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 30, 2026 - 01:03 UTC

Investigating

Mux Data Views for EU customers are delayed beginning 22:53 UTC. We are investigating
Posted Apr 30, 2026 - 00:22 UTC
This incident affected: Mux Data - Data Collection.