Mux Data Monitoring Issues

Incident Report for mux

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 08:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Latency has returned to normal.
Posted Mar 03, 2026 - 07:55 UTC

Identified

The issue has been identified and we are implementing a fix. Latency in the system is reduced, but still remains for some customers.
Posted Mar 03, 2026 - 07:42 UTC

Update

We are continuing to investigate and will post as soon as we know more.
Posted Mar 03, 2026 - 06:36 UTC

Update

We are continuing to investigate and are seeing significant latency in our collection pipeline.
Posted Mar 03, 2026 - 05:56 UTC

Investigating

We are currently investigating an issue with our Mux Data Monitoring collection pipeline. Data may be delayed or missing beginning 05:14 UTC
Posted Mar 03, 2026 - 05:29 UTC
This incident affected: Mux Dashboard and Mux Data - Data Collection.