Possible Mux Data historical metrics delays

Incident Report for mux

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 23:57 UTC

Monitoring

Our team has implemented a fix to resolve the delayed historical metrics, and is monitoring the situation.
We’ll post an update as soon as the issue is fully resolved.
Posted Jan 09, 2026 - 23:25 UTC

Identified

Our team has identified a cause to delayed historical data and is actively working on a fix. We’ll continue to share updates as we have them.
Posted Jan 09, 2026 - 23:15 UTC

Investigating

We are currently investigating possible delays in Mux Data historical metrics beginning at approximately 19:55 UTC. We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 09, 2026 - 22:51 UTC
This incident affected: Mux Data - Data Collection.