Increased error in Video Live and VOD

Incident Report for mux

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 13:18 UTC

Monitoring

Video delivery for Live and VOD in the impacted region has returned to normal operations.  The impacted time frame was 9:30 - 10:30 UTC.  We are continuing to monitor.
Posted Jun 18, 2026 - 11:31 UTC

Identified

We've identified an issue with a CDN provider in the impacted regions. We are seeing recovery, and continuing to monitor.
Posted Jun 18, 2026 - 10:57 UTC

Investigating

We are experiencing increased errors with delivery across Live and VOD in Europe regions  and are actively investigating.
Posted Jun 18, 2026 - 10:16 UTC
This incident affected: Mux Video - VOD and Mux Video - Live.