Partial Data Collection Outage due to DNS resolution failures
Incident Report for Mux
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 03:31 UTC
Monitoring
We have resolved the DNS resolution issues and continue to monitor the system. At this point, data collection and SDK serving are functioning as expected. Note, some clients might need to refresh their DNS cache.
Posted Nov 02, 2020 - 02:23 UTC
Identified
The issue with DNS resolution is due to a DoS attack on a third party vendor that Mux Data relies on for DNS. At this time, DNS resolution of all *.litix.io domains will sporadically work, resulting in a partial data collection outage for Mux Data, as well as making any Data SDKs hosted on src.litix.io unavailable.

We are investigating potential workarounds at this time and will post an update as soon as we have one.
Posted Nov 02, 2020 - 00:56 UTC
Investigating
We are investigating an issue where certain domain records for our *.litix.io domain fail to resolve sporadically. At this time, this can result in Data SDKs being unavailable from src.litix.io, as well as a partial data collection outage for Mux Data customers.
Posted Nov 02, 2020 - 00:34 UTC
This incident affected: Mux Data - Data Collection.