This incident has been resolved. Between 16:40 UTC and 17:36 UTC, webhook events were delivered with delays averaging around 5 minutes, with some events delayed up to 15 minutes. Video processing, playback, and API requests were unaffected, and no events were lost — all delayed webhooks have been delivered.The underlying issue in one of our internal database clusters has been addressed, and delivery times have been stable since 17:36 UTC. We apologize for the disruption.
Posted Sep 24, 2026 - 18:21 UTC
Monitoring
Webhook delivery times have returned to normal. Between 16:40 UTC and 17:36 UTC, webhook events were delivered with delays averaging around 5 minutes, with some events delayed up to 15 minutes. Video processing, playback, and API requests were unaffected, and no events were lost — all delayed webhooks have been delivered.We have addressed the underlying issue in one of our internal database clusters and are monitoring to confirm.
Posted Sep 24, 2026 - 17:51 UTC
Identified
We have identified the cause of the elevated webhook delivery times. An issue in one of our internal database clusters introduced a delay in the pipeline that queues webhook events, resulting in delivery delays beginning at 16:40 UTC. Video processing, playback, and API requests are unaffected, and no events have been lost — delayed webhooks are still being delivered. Delivery times are beginning to recover.
Posted Sep 24, 2026 - 17:44 UTC
Investigating
We are currently investigating elevated webhook delivery times. Beginning at 16:40 UTC, some webhooks are being delivered with a delay of approximately 5 minutes. Video processing, playback, and API requests are not affected, and no webhook events are being dropped — delayed events will still be delivered. We will provide an update as soon as we have more information.
Posted Sep 24, 2026 - 17:37 UTC
This incident affected: Mux Video - VOD and Mux Video - Live.