Video Storage Service Elevated Error Rate

Incident Report for mux

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 19:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 18, 2025 - 16:33 UTC

Monitoring

Systems are recovering and we are being monitored
Posted Jul 18, 2025 - 16:26 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 15:49 UTC

Update

Currently observing degraded video delivery and elevated ingestion times.
Posted Jul 18, 2025 - 15:47 UTC

Investigating

We are currently investigating this issue.
Posted Jul 18, 2025 - 15:32 UTC
This incident affected: Mux Video - VOD and Mux Video - Live.